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1.1 What’s changed from PD² v4.1c to v4.1e? 

The functionality of how clauses are ordered in the Clauses tab, changed from PD² v4.1c to PD² v4.1e.  This 
document will explain the logic used by PD² to order clauses in PD² v4.1e.  The important difference to note, 
is that in PD² v4.1c users had more flexibility to order clauses (they could drag and drop clauses into the 
order in which they wanted them to be generated in the document).   

In PD² v4.1e, all clauses are ordered for the user using the logic/rules outlined in the sections that follow.  
The user does not have the ability to drag and drop the clauses into an order different that the order in which 
the system puts the clauses after generation.  The only way the user can manipulate the clause order in the 
Clauses tab is to change the description (Refer to Section 1.4: Using the Description Field to order Add Text 
items).   

1.2          Upgrading PD² v4.1c documents 

The order in which clauses are displayed in the Clauses tab on documents released in PD² v4.1c will 
automatically be updated to follow the rules of clause ordering in PD² v4.1e, after the upgrade.  The user does 
not have the ability to drag and drop the clauses into a different order, so the user will not be able to correct 
the way the clauses display in PD² v4.1e to reflect the way they displayed in the document prior to the 
upgrade.  Creating a modification or amendment and “dragging” and “dropping” the clauses into the order 
the user desires will not work in PD² v4.1e.  The only method to update the order of clauses in a released 
document is to create an amendment or modification, delete the clauses, then re-add the clauses after 
changing the description of the clause (Refer to Section 1.4: Using the Description field to order Add Text 
items).   

1.3          Defining terms commonly used in this document. 

 Clauses tab: The last tab in the PD² document (on-line).  To access the Clauses tab, open the PD² document 
and select the Clauses tab. 

 

[Add Text] items: For the purpose of explaining how PD² orders clauses in the Clauses tab and the printed 
document, we refer to [Add Text] items as those items which are created in the Clauses tab, by clicking 
[Add Text].  All items that created on the Clauses tab, using the [Add Text] button are [Add Text] items, 
regardless of the content of the item (local clause, provision, or otherwise).    

 

FAR, DFARS and Local Clauses: Clauses added to the Clauses tab by clicking [Add Clause].  The content 
of these clauses must be added through the Clauses Task in System Administration.  
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Local Clauses: Clauses added to the Clauses tab after clicking [Add Clause].   The text of these clauses 
must be added through the Clauses Task in System Administration.  These clauses are not part of the 
Standard Data set, which includes all FAR and DFARS clauses, and display in the Clauses Task when PD² is 
initially installed. 

All other items, which display in the Clauses tab (ie, CLIN information, Delivery, Inspection Information, 
Accounting and Appropriation Data), will not be discussed.  These items always display at the top of each 
UCF Document section. 

1.4   Using the Description field to order [Add Text] items  

In the sections that follow we will discuss how [Add Text] items are ordered numerically then alphabetically, 
after the document is generated. By changing the text in the Description field, when text items are added to 
the Clauses tab, the user can manipulate the order in which the [Add Text] items display in the Clauses tab 
of a document. Click [Add Text] on the Clauses tab to view the New Text Item window.  Enter the 
description of the [Add Text] item in the Description field in the New Text Item window. 

 

1.5 Selecting UCF Format 

If you open a PD² document and select Document Options>Classification, the Document 
Classification window opens.  To select a format type for the PD² document, select a format from 
the Document Format drop-down list box in the Classification window. When UCF is selected 
from the Document Format drop down list box, PD² will sort all [Add Text] items, FAR, 
DFARS and Local clauses in the Clauses tab in the order outlined in the sections that follow. 
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1.5.1 UCF Format: SECTIONS B to M, not including J 

UCF: SECTIONS B to M, not including J – Clauses tab, after the document has been generated. 

All [Add Text], FAR, DFARS and Local clauses are ordered numerically, then alphabetically.  For an 
example of how [Add Text], FAR, DFARS and Local clauses are ordered in the Clauses tab, after a 
document has been generated, but before the document has been closed, see Table 1. Numeric values are not 
listed “sequentially”.  This means an [Add Text] clause with the description “10” will appear after an [Add 
Text] item with the description “1”, but before the [Add Text] clause with the description “2”.   

To work around this error, enter “0” in the Description field before numbers less than “10” if numbers have 
been entered in the Description field of the [Add Text] item, up to “99” in that section (ie, 01, 02…99).  
Enter “00” in the Description field before numbers less than “10” if numbers have been entered in the 
Description field of the [Add Text] item, up to “999” in that section (ie, 001, 002…999).  Enter  “000” in 
the Description field before numbers less than “10” if numbers have been entered in the Description field of 
the [Add Text] item, up to “9999” in that section (ie, 0001, 0002…9999). 

 

Table 1. Clauses (with the following descriptions) appear on the Clauses tab in the order outlined below, 
after the document has been generated, but before the document has been saved and closed. 

Description By Ref/Full Text Clause Type 

1 N/A [Add Text] item  

10 N/A [Add Text] item  

11.111-2 By Reference Local  

2 N/A [Add Text] item  

252.201-7000 By Reference DFARS  

252.203-7001 By Reference DFARS  

52.202-1 By Full Text FAR  

52.202-1 Alt 1 By Reference FAR  

52.203-2 By Reference FAR  

A N/A [Add Text] item  

B N/A [Add Text] item  
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UCF: SECTIONS B to M, not including J – Clauses tab, after the document has 
been generated, saved, and closed. 

Refer to Table 1 for an example of how [Add Text], FAR, DFARS and Local clauses are displayed in the 
Clauses tab after a document is generated, but before the PD² document is saved and closed. 

The order changes in the Clauses tab after the document has been generated, saved, closed and reopened.  
After you generate, save, close and reopen the document the [Add Text] items are listed before the FAR, 
DFARS and Local clauses.   

Refer to Table 2 for an example of how [Add Text], FAR, DFARS and Local clauses are displayed in the 
Clauses tab after the PD² document has been generated, saved, closed and reopened.  

 

Table 2.   [Add Text] items are displayed before FAR, DFARS and Local Clauses in the Clauses tab after 
the PD² document has been generated, saved, closed and reopened.  

Description By Ref/Full Text Clause Type 

1 N/A 

10 N/A 

2 N/A 

A N/A 

B N/A 

 

 

[Add Text] 

[Add text] items are listed numerically, then 
alphabetically.  Numeric values are not listed 
sequentially. 

11.111-2 By Reference 

52.202-1 By Full Text 

52.202-1 Alt 1 By Reference 

52.203-2 By Reference 

252.201-7000 By Reference 

252.203-7001 By Reference 

 

 

FAR, DFARS and Local 

FAR, DFARS and Local clauses (items 
added to the Clauses tab by clicking [Add 
Clause]) are listed sequentially, regardless of 
how they are incorporated (by Reference, or 
by Full Text). 
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UCF: SECTIONS B to M, not including J –Print Preview and View Document 

To view the text of the generated Microsoft Word document: 

1. Highlight the PD² document icon on your desktop and select File>Print Preview; or, 

2. Open the PD² document and select Document Options>View Document.  (When a generated 
document is viewed by selecting View Document from the menu bar, only the continuation pages will 
display).   

3. If you are opening an SF 30 modification or amendment by selecting File>Print Preview or Document 
Options>View Document, click on the [Conformed Document] button when the Choose document 
type window opens.  

Refer to Table 3 for an example of how PD² orders clauses in the generated Microsoft Word document.  In 
the printed document the order, in which [Add Text], FAR, DFARS and Local clauses are displayed, 
changes.   

• FAR, DFARS and Local clauses (added to the Clauses tab by clicking [Add Clause]), which are 
incorporated By Reference, display first.  Clauses listed By Reference in the generated Microsoft Word 
document are listed sequentially in the order in which they are listed in the Clauses tab, after the 
document has been generated, saved and closed. 

• The text of all [Add Text] items and FAR, DFARS and Local clauses, incorporated By Full Text, are 
listed after FAR, DFARS, and Local clauses incorporated By Reference.  The text of all [Add Text] 
items is listed first.  The text of all [Add Text] items is listed in the generated Microsoft Word document 
in the order in which the [Add Text] items display in the Clauses tab.  The text of all FAR, DFARS and 
Local clauses is listed in the generated Microsoft Word document after the text of all [Add Text] items.  
The text of all FAR, DFARS and Local clauses, incorporated By Full Text, is listed in the same order in 
which the clauses display in the Clauses tab, after the PD² document has been generated, saved and 
closed. 
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Table 3. In the generated Microsoft Word document, [Add Text] items are listed before all FAR, DFARS 
and Local Clauses incorporated By Full Text. The [Add Text] items and the FAR, DFARS and Local Clauses 
are listed in the generated Microsoft Word document in the order in which they display in the Clauses tab, in 
the PD² document, after the document has been generated, saved and closed. 

Description By Ref/Full Text Clause Type 

11.111-2 

52.202-1 Alt 1 

52.203-2 

252.201-7000 

252.203-7001 

By Reference 

FAR, DFARS and Local clauses (clauses 
added, by clicking [Add Clause]), 
incorporated by Reference are listed at the 
beginning of each section. 

FAR, DFARS and Local 

FAR, DFARS and Local clauses (clauses 
added by clicking [Add Clause]) are 
listed sequentially, as displayed in the 
Clauses tab. 

 

1 

10 

2 

A 

B 

N/A  

The text of  [Add Text] items are listed 
after all clauses by Reference.  

Add Text 

The text of all [Add Text] items are listed 
in the continuation pages in the order in 
which the [Add Text] items appear in the 
Clauses tab. 

52.202-1 By Full Text 

The text of all FAR, DFARS and Local 
clauses are listed after all [Add Text] 
items. 

FAR, DFARS and Local 

The text of FAR, DFARS and local 
clauses, incorporated by Full Text, are 
listed in the continuation pages in the 
same order the clauses appear in the 
Clauses tab. 
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1.5.2 UCF Format: Section J 

UCF: SECTION J – Clauses tab, before and after the PD² document has been 
generated, saved and closed. 

All attachments that display in the Clauses tab, in Section J, are added to the Clauses tab by selecting the  
[Add Text] button.  Refer to KB article #37748 (http://kb.ams.com/ID/37748/) for instruction on how to add 
attachments to section J in PD² v4.1e. Just as clauses in other sections of a UCF document, [Add Text] items, 
in Section J, are ordered numerically then alphabetically, after the PD² document and Section J has been 
generated.  Numeric values are not listed “sequentially”.  This means, an [Add Text] item in Section J, where 
“10” has been entered at the beginning of the Description field in the New Item Text window, will display 
after an [Add Text] item in Section J where “1” has been entered at the beginning of the Description field,  
and before an [Add Text] item in Section J where  “2” has been entered in the Description field.   

To work around this error, enter “0” in the Description field before numbers less than “10” if numbers have 
been entered in the Description field, of the [Add Text] item, up to “99” in that section (ie, 01, 02…99).  
Enter “00” in the Description field before numbers less than “10”, if numbers have been entered in the 
Description field of the [Add Text] item up to “999” in that section (ie, 001, 002…999).  Enter  “000” in the 
Description field before numbers less than “10” if numbers have been entered in the Description field, of the 
[Add Text] item, up to “9999” in that section (ie, 0001, 0002…9999).The “Table of Contents” clause is 
automatically generated when you select Document Options Generate Section J.  It is listed with the 
other [Add Text] items in alphabetical order.  

The order of clauses in Section J does not change after the PD² document has been generated, saved and 
closed.  The [Add Text] items in section J display in the generated PD² document in the same order before 
and after the PD² document has been saved and closed.  

Refer to Table 4 for an illustration of how [Add Text] items in Section J display in the Clauses tab, after the 
PD² document and Section J have been generated, and the PD² document has been saved and closed. 

 

Table 4.  [Add Text] items, added to Section J, display in numeric, then alphabetical order in the 
Clauses tab of the generated PD² document.  NB:  The Table of Contents is an item in Section J, 
in the Clauses tab, which automatically displays in Section J, and is not added by the User. 

Description By Ref/Full Text Clause Type 

Attachment 1 N/A [Add Text]  

Section J Attachment N/A [Add Text]  

Table of Contents N/A <Auto> 

Test Attachment N/A [Add Text]  
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UCF: SECTION J – Print Preview and View Document 

The text of all [Add Text] items in Section J display, in the generated Microsoft Word document, 
in the same order as they display in the Clauses tab in the PD² document.  The one exception is the 
Table of Contents, which always displays at the top of Section J in the generated Microsoft Word 
document.  Refer to Table 5 for an illustration of how the text of the [Add Text] items in Section J 
and the Table of Contents displays in the generated Microsoft Word. 

 

Table 5. The text of all [Add Text] items in Section J display in the generated Microsoft Word 
document in the same order as they display in the Clauses tab in the PD² document.  The one 
exception is the Table of Contents, which always displays at the top of Section J in the generated 
Microsoft Word document. 

Description By Ref/Full Text Clause Type 

Table of Contents N/A <auto> 

Attachment 1 N/A [Add Text]  

Section J Attachment N/A [Add Text]  

Test Attachment N/A [Add Text]  

 


	What’s changed from PD² v4.1c to v4.1e?
	Upgrading PD² v4.1c documents
	Defining terms commonly used in this document.
	Using the Description field to order [Add Text] items
	Selecting UCF Format
	UCF Format: SECTIONS B to M, not including J
	UCF Format: Section J


